Dirol3434
14.08.2020 00:42

4. напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r или s. 5. напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a; b), или 0 в противном случае

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Клямпер
05.07.2020 22:42
1.
var a,b,r,s:integer;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите остатки r и s: ');
readln(r,s);
if (a mod b=r) or (a mod b=s) then writeln('Да, верно')
  else writeln('Нет, неверно')
end.

2.
var a,b,x:real;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите x: ');
readln(x);
if (a<=x) and (x<=b) then writeln(1)
  else writeln(0)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота