umnikummmmmm
31.05.2022 04:40

Написать программу, которая вставляет число k в заданную возрастающую последовательность таким образом, что в результате полученная последовательность также остается полностью возрастающей. (язык программирования - паскаль) - писать адекватно

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
айка395
06.07.2020 22:35
Var a:array[1..11] of integer;
i,k,t:integer;
begin
for i:=1 to 10 do
read(a[i]);
read(k);
for t:=1 to 11 do

if a[t]>k then break;
for i:=11 downto t+1 do
a[i]:=a[i-1];
a[t]:=k;
for i:=1 to 11 do
write(a[i],' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота