LediDiana2005
15.01.2020 17:53

Составить программу согласно следующему условию. дан одномерный массив а из n элементов.осуществить операцию циклического сдвига на 1 элемент вправо. и блок схему бы еще

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vitalina05062005
01.10.2020 21:26
На C++

#include <iostream.h>
 const n=10;
  void main()
{ int b,A[n]={1,2,3,4,5,6,7,8,9,0};
   b=A[n-1];
    for(int i=n-2;i>=0;i--) A[i+1]=A[i];
    A[0]=b; for(i=0; i<n;i++)
    cout<< A[i]<<','; }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота