katiapopovici
31.05.2022 05:32

:с нужно составить алгоритм на языке программирования паскаль. дан массив, состоящий из 10 элементов. определите, сколько элементов этого массива имеют максимальное значение.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MaМа
07.07.2020 11:20
Var a:array[1..10] of real;
b,c:integer;
max:real;
begin
c:=0;
writeln('Введите элементы массива');
for b:=1 to 10 do
begin
readln(a[b]);
end;
max:=a[1];
for b:=1 to 10 do
begin
if a[b]>max then max:=a[b];
end;
for b:=1 to 10 do
begin
if a[b]=max then c:=c+1;
end;
writeln('Количество элементов,имеющих максимальное значение равняется ',c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота