kioppo
14.09.2020 11:29

Составьте программу на языке паскаль: поменять местами первую и последнюю цифры четырёхзначного числа. !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dmitr55
07.07.2020 12:52
Var a,a1,a2,a3,a4;
begin
read (a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
a:=a4*1000+a2*100+a3*10+a1;
write (a);
end.
0,0(0 оценок)
Ответ:
DImonist
07.07.2020 12:52
Uses Crt;
var   x : Integer; 
Zn:Char; 
strNum:string;  
begin  
ClrScr; 
Write('Введите четырех значное число: '); 
ReadLn(x);   
Str(X,strNum); 
Zn:=strNum[1]; 
strNum[1]:=strNum[Length(strNum)]; 
strNum[Length(strNum)]:=Zn; 
x:=StrToInt(StrNum); 
writeln(strNum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота