EllenOnyschuk
07.11.2020 04:08

Срешением двух ! . нужно написать программу на паскаль, заранее, ! ) в двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовдан двумерный массив a[n,n]. сформировать одномерный массив в, состоящий только их элементов главной диагонали.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pminikrolik
07.07.2020 13:14
Var a: array[1..5,1..5] of integer;
pol,i,j:integer;
begin 
randomize;
for i:=1 to 5 do 
 for j:=1 to 5 do  a[i,j]:=random(100)-50;
for i:=1 to 5 do
  for j:=1 to 5 do  if a[i,j]>0 then inc(pol);
write(pol);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота