Манdarinka
31.12.2022 22:11

Составьте программу, которая по введенному вами k - числу грибов печатает фразу , причем согласовывает окончание слова с числом k. количество грибов может быть любым целым числом: 1, 3, 34, 127 и т.д. окончание фразы определяется значением последней цифры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
К1а2т3я456
07.07.2020 13:20
Var g,i:integer;
begin 
read(g);
if (g=1) or ((g>20) and (g mod 10=1)) then begin writeln('Мы нашли в лесу ',g,' гриб'); i:=1; end;
if ((g mod 10>1) and (g mod 10<5)) or ((g>21) and (g mod 10>1) and (g mod 10<5)) then begin writeln('Мы нашли в лесу ',g,' гриба'); i:=1; end;
if i=0 then writeln('Мы нашли в лесу ',g,' грибов');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота