lflflflfgh
10.02.2022 00:12

Паскаль составить программу найти сумму ряда с точностью =10-3 , общий член которого an = ((3^n)*n! )/ (2n)!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
velvis2050
07.07.2020 23:46
Паскаль АВС

Program LoctarUgar;
uses crt;
const
  eps=0.001;

function fact(n : integer) : longint;
  begin
    if n <= 1
         then  fact := 1
         else   fact := n * fact(n - 1);
  end;

var
  t,s:real;
  i:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Программа вычисляет частичную сумму ряда с заданной точностью');
  writeln('  Общий член ряда:  an = ((3^n)*n! )/ (2n)!');
  writeln('Вычисление прекратится, когда модуль очередного слагаемого станет меньше 0,001');
  writeln();
  s:=0;   i:=1;   t:=1;
  while t>eps do
    begin
      t:=(power(3,i)*fact(i))/(2*fact(2*i));
      s:=s+t;
      writeln('a(',i,')=',t:0:6,'  S=',s:0:6);
      i:=i+1;
     end;
  writeln();
  writeln('Сумма ряда равна',s:0:6);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота