radmirnemyshov
18.03.2021 02:11

Решить в паскале 1) составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6. 2) введено 3-значное число. вывести число в зеркальном отображении. 3)введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
serguhovaannagmail
01.10.2020 22:46
Program task1;
var  a :integer;
begin
  randomize;  a:= 0;  while (a <> 5) and (a <> 6) do    a:= random(7);  writeln(a);
end.

program task2;
var  Digit, i :integer;  DigitStr :string;
begin
  readln(Digit);  str(Digit,DigitStr);  for i:= length(DigitStr) downto 1 do    write(DigitStr[i]);
end.

program task3;
var  Digit :integer;  NewDigit, DigitStr :string;
begin
  readln(Digit);  str(Digit,DigitStr);  NewDigit:= DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2];  writeln(NewDigit);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота