asanovatoma1
20.10.2021 01:45

Написать программу на создать файл а4, состоящий из 28 целых чисел. найти среднее арифметическое всех чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Женя111сивар
01.10.2020 22:48
Program abc;
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
  x, y: longint;
  i: byte;
begin
  y := 0;

  assign(f, 'a4');
  reset(f);

  for i := 1 to 28 do
  begin
    read(f, x);
    y := y + x;
  end;

  writeln(y / 28);
  close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота