LoVE3223
13.03.2021 08:09

Построить блок схему алгоритма и написать программу для решения: даны действительные числа z,y,x.если сумма двух чисел x y меньше единицы ,то каждое из заданных трёх чисел заменить полусуммой двух других,в противном случае возвести в квадрат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gaxling
08.07.2020 01:45
var
  x, y, z: real;
  a, b, c: real;
  
begin
  readln(x, y, z);
  if (x + y < 1) then
  begin
    a := (y + z) / 2;
    b := (x + z) / 2;
    c := (x + y) / 2;
    x := a;
    y := b;
    z := c;
  end
  else
  begin
    x := sqr(x);
    y := sqr(y);
    z := sqr(z);
  end;
  writeln(x, ' ', y, ' ', z);
end.
Построить блок схему алгоритма и написать программу для решения: даны действительные числа z,y,x.есл
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота