ychenik555555555
13.03.2021 18:20

Написать программу в паскале напишите программу, подсчитывающую количество различных букв в заданном слове. входные данные: ввести строкy y с длиной не более 255 символов. выходные данные: вывести одно число, количество различных символов в данной строке.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
iavorskayavika
01.10.2020 22:48
var
  y, b: string;
  i: integer;

begin
  readln(y);
  for i := 1 to length(y) do
    if (Pos(y[i], b) = 0) then
      b := concat(b, y[i]);
  writeln(length(b));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота