Алисика11
15.01.2022 09:10

Написать программу перевода числа из двоичной системы в десятичную с использованием функции возведения в степень. я написала, но у меня где-то ошибка. b: =0; m: =length(max)-1; j: =m; for i: =1 to m do begin val(max[i],p,code); while j> =0 do p: =p*step(2,j); b: =b+p; j: =j-1; writeln(b); end; поясняю, что тут и как. эта мини-, входящая в решение одной масштабной . дана строка max, в которой записано двоичное число. функция step(x,y: integer): integer возводит число x в степень y. найти и исправить ошибку, только, , не надо писать совершенно другой решения. заранее ))

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
S2a0h0i6b
01.10.2020 23:04
Begin
 
  max := '1010';
  b := 0;
  m := length(max);
  j := m - 1;
 
  for i := 1 to m do
 
  begin
   
    val(max[i], p, code);
   
    {while j >= 0 do}
   
    p := p * step(2, j);
   
    b := b + p;
    j := j - 1;
   
    writeln(b);
   
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота