Still227
04.08.2022 15:31

Написать программу на turbopascal. дано натуpальное n. записать в файл целые числа , где bi=i2-2i+1 при i=1,. найти сумму всех четных чисел в файле.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
axmet2
27.04.2023 13:34
Задача №1
var a:array[1..4, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов кратных 3-м и > 20 = ',k); 
end.

Задача №2
var a:array[1..5, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 5 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if i=j then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов главной диагонали = ',k); 
end.
0,0(0 оценок)
Ответ:
nbolshakova1
03.01.2023 21:29
1) файл паскаля приложен.
2) код на c#
        static void Main(string[] args)        {            int a, b;            a = Convert.ToInt32(Console.ReadLine());            b = Convert.ToInt32(Console.ReadLine());            if (a > 2)            {                Console.WriteLine(a / 2);                Console.WriteLine(b - 1);            }        }
3) Код на vb
dim a as integer = 0
dim b as integer = 0
a = cint(console.readline())
b = cint(console.readline())
if a > 2 then
console.writeline( a / 2)
console.writeline(b - 1)
end if
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота