nikonova1977
17.06.2022 10:32

Задать массив из n элементов. значения вести с клавиатуры. написать программу, уменьшающую все элементы массива на единицу. вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив. для перехода на новую строку добавить writeln. это все в pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Fataeh
13.07.2020 10:19
Const n=10000;
var a:array [1..n] of integer;
b:array [1..n] of integer;
i, k:integer;
begin
Writeln ('Введите число элементов массива');
readln (k);
for i:=1 to k do begin
Writeln ('Введите ',i,' элемент массива'); readln (a[i]); end;
for i:=1 to k do begin b[i]:=a[i]-1; end; 
Writeln ('Первоначальный массив:'); 
for i:=1 to k do begin writeln (a[i]); end; 
Writeln ('Конечный массив:'); 
for i:=1 to k do begin writeln (b[i]); end; 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота