thebesteconomist
21.03.2021 20:52

Написать программу, которая вычисляет сумму первых n четных положительных чисел. исходные данные (n – количество чисел) вводятся с клавиатуры. результаты работы программы записываются в файл out.txt.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
scarletvalkiria
15.07.2020 09:15
Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся из файла Input.txt. Результаты работы программы записываются в файл Out.txt. 
Вопрос в том что я написал программу: и вывел чтоб он считал сумму четных чисел а сумму считает не правильно 

вот программа: 

//
#include <stdio.h> 
#include <conio.h> 
#include <math.h> 
//
int main () 
{ 
FILE *f1, *f2; 
int n, i; 
float s; 
f1 = fopen("input.txt", "r"); 
f2 = fopen("out.txt", "w"); 
fscanf (f1, "%d", &n); 
for (i=1; i<=n; i++) 
{ 
if ((n>0) && (i%2==0)) 
fprintf(f2, "=", i); 
} 
s=0; 
{ 
s=(float)s+i; 
fprintf(f2,"\n Summa=%f", s); 
} 
fclose(f1); 
fclose(f2); 
getch(); 
return 0; 
} 
//
Дополнен 2 года назадв общем то я понял то что сумму он считает так то что впишу в файл к примеру 5 он к этому числу просто прибавляет 1 и все а мне нужно чтоб он считал все четные числа которые вывелись к примеру написал 6 он должен сложить 2+4+6 будет 12 а он пока делает я ввел 6 к нему 6+1 и 7 типаДополнен 2 года назадвот программа в паскале 
както так
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота