olesya3010ozvprt
03.03.2021 06:31

Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов. два первых элемента задайте с клавиатуры. напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й - равен случайному числу, отличному от нуля; 2-й - равен квадрату предыдущего элемента; 3-й - равен целой части частного от деления двух предыдущих элементов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
artemkovalev1
15.07.2020 17:29
1. var a:array [1..100] of integer;
i,n:integer;
begin
read(n); {количество эл. массива}
read (a[1], a[2]);
for i:=3 to n do
a[i]:=a[i-1]+a[i-2];
for i:=1 to n do
write (a[i],' ' );
end.

2.const m=6;n=3;
var a:array [1..100,1..100] of integer;
i,j:integer;
begin
for i:=1 to m do
read (a[i,1]);
for i:=1 to m do
begin
j:=1;
a[i,j+1]:= sqr(a[i,j]);
a[i,j+2]:= a[i,j] div a[i,j+1]; {это условие мне не совсем понятно}
end;
for i:=1 to m do
begin
for j:=1 to n do
write (a[i,j]:3);
writeln;end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота