YtNazarIdline
07.10.2021 01:22

Составить программу паскаль и объясните ее дано четырехзначное число,получить новое поменяв местами первую и последнюю цифру

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dilya091
02.10.2020 05:26
Program zamena;
var s:string;
     x,y:char;
begin
write('Введите четырехзначное число: ');
readln(s);
x:=s[1]; y:=s[4];
s[1]:=y; s[4]:=x;
writeln('Полученное число: ',s);
end.

Считываем число как строку. Символьной переменной "X" присваиваем значение первого символа строки (первой цифры числа). Символьной переменной "Y" присваиваем значение четвертого символа строки (четвертой цифры числа). Делаем обмен первой и четвертой цифры числа: присваиваем первому символу значение переменной "Y", а четвертому символу - значение переменной "X". Выводим получившуюся строку (число) на экран.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота