барц2005
14.08.2020 22:03

Написать программу, которая вводит массив и заменяет в нем все элементы, которые превышают 7, этим числом. вывести массив и кол-во замен.(в pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
катюшка309
25.05.2020 21:17

const  

n=10;

var  

a : array [1..n] of integer;

i,k,m : integer;

begin

randomize;

k:=0;

writeln('введите число, на которое заменять элементы: ');

read(m);

writeln('Массив:');

for i:=1 to n do  

 begin

   a[i]:=random(10)+1;

   write(a[i]:4);

 end;

writeln;

for i:=1 to n do  

 if (a[i]>7) then  

   a[i]:=m;

writeln('изменённый массив:');

for i:=1 to n do  

 write(a[i]:4);

end.  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота