AnnaKaramelka6684
01.07.2022 00:07

Дано целое трехзначное положительное число n. составьте программу которая определяет входит ли в него цифра восемь.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Abuhgghhhhhh
17.07.2020 00:02
Const ch=8;
var n:integer;
begin
read(n);
while n>0 do begin
if(n mod 10=ch)then begin
writeln('yes'); break;
end;
n:=n div 10;
end;end. 
еще можно в строку преобразовать и посимвольно проверить, но мне кажется так нагляднее и алгоритм проще
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота