DASHAMIronovAAA
11.10.2020 19:21

Написать программу в си++ радиус круга задать в главной функции. по желанию пользователя в отдельной функции вычислить, либо площадь круга, либо длину окружности. результат вывести в главной функции

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
konkina
02.10.2020 07:38

Писал в Visual Studio, выбор пользователя есть. Проверки сделал, все верно считает. Код :

#include "stdafx.h"

#include <iostream>

#include <windows.h>

using namespace std;

double zadanie(double R, bool a)

{

double otvet = 0;

switch (a)

{

case 0:

 {

 otvet = (3.14*R*R); // S = pi * R^2

 break;

 }

case 1:

 {

 otvet = (2*R*3.14); // L = 2 * R * pi

 break;

 }

}

return otvet;

}

int main()  

{

setlocale(LC_ALL, "Russian");

bool menu; // 0 - Площадь, 1 - Длина окружности.

double radius = 0;

cout << "Введите радиус круга: ";

cin >> radius;

cout << "\nВыберите расчет: \n" << "[0] Площадь круга \n" << "[1] Длина окружности круга \n\n" << "Пункт: ";

cin >> menu;

cout << "\nответ: " << zadanie(radius, menu) << endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота