szaikin
16.04.2020 23:40

Дан массив, состоящий из целых чисел(до 10000) напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Salahaddin001
17.07.2020 11:21
Const
  n = 20;

var
  a: array[1..n] of integer;
  i: integer;
  flag: boolean;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(19999) - 9999;
    Write(a[i]:6);
  end;
  Writeln;
  i := 1;
  flag := False;
  repeat
    flag := (sign(a[i]) = sign(a[i + 1]));
    i := i + 1
  until flag or (i > n);
  if flag then Writeln('Есть пара соседних элементов с одним знаком')
  else Writeln('Нет пар соседних элементов с одним знаком')
end.

Тестовое решение:
Элементы массива
  2440 -2414 -3192 -6912 -8537  7364  2869 -2505  8875  2662   401  7398  2213  8804  2039  1485  4213  8359 -2410 -5844
Есть пара соседних элементов с одним знаком
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота