Напишите программу на паскале abc которая вводит натуральное число n и выводит на экран все натуральные числа не превосходящие n и делящиеся на кадлую из своих цифр
begin Write('Введите верхнюю границу для счета: '); Readln(k); for i := 1 to k do begin n := i; repeat d := n mod 10; if d > 0 then flag := ((i mod d) <> 0) else flag := true; if (not flag) then n := (n div 10) until (flag or (n = 0)); if n = 0 then Write(i, ' ') end; Writeln end.