Михалкова
07.02.2023 05:28

Даны коэффициенты квадратного уравнения a,b,c.напишите программу которая решает это квадратное уравнение.(в паскале)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Stillyxa
17.07.2020 16:55
Program Uravnenie;
uses Crt;
var a,b,c,x,x1,x2 : real ;
begin     
clrscr;
     writeln ( 'Введите a : ' );
     readln ( a );
     writeln ( 'Введите b : ' );
     readln ( b );
     writeln ( 'Введите c : ');
     readln ( c );
     if ( sqr ( b ) - 4 * a * c ) < 0
               then  writeln ( ' Уравнение не имеет решения ' )                                   else begin                         
if ( sqr ( b ) - 4 * a * c ) = 0 
                        then begin
                                   x:= - b / ( 2 * a );
                                   writeln( ' x = ', x : 8 : 2 )
                              end                         
else
 begin                                 
      x1:= ( - b + sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
      x2:= ( - b - sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
      writeln( ' x1 = ', x1 : 8 : 2, ' x2 = ', x2 : 8 : 2 ) 
end
end.
0,0(0 оценок)
Ответ:
Fvbygbb
17.07.2020 16:55
Program s;
var a,b,c,x,z,d:real;
begin
write('Введите a,b,c');
read(a,b,c);
d:=(b*b)-(4*a*c);
if d<0 then write(' Уравнение не имеет корней')
else
x:=(-b+sqrt(d))/(2*a);
z:=(-b-sqrt(d))/(2*a);
write(' х равно ',x, ', ', z);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота