dionis01
25.10.2021 22:05

1)напишите программу, которая заполняет матрицу случайными числами, а затем записывает нули во все элементы выше побочной диагонали. 2)напишите программу, которая заполняет матрицу случайными числами, а затем записывает нули во все элементы выше главной диагонали. ! (питон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Felua
21.02.2021 06:23

Обычно предполагается, что нам известны какие-либо начальные данные. Тогда для простоты, буду считать что нам известно основание и высота к этому основанию. В таком случае

S = основание * высоту / 2

Что нужно сделать?

1) Запросить у пользователя ввод длины основания

2) Запросить у пользователя ввод длины высоты

3) Вычислить площадь

4) Вывести площадь на экран

Определимся с данными. У нас будет переменная S, основания и высоты. Все будут real, ведь пользователь может ввести и не целое число.

program ploshad;

var S, osnovanie, visota:real;

begin

   writeln('Вычисление площадь треугольника по основанию и высоте');

   writeln('Введите длину основания ');

   read(osnovanie);

   writeln('Введите длину высоты ');

   read(visota);

   S:=osnovanie*visota/2;

   writeln('Площадь треугольника = ',S);

end.

0,0(0 оценок)
Ответ:
Evagevko
24.03.2020 06:33

Писать код можно в любой среде разработки: SharpDevelop, Microsoft Visual Studio, и другие - от них ничего не зависит для новичка.

Если Вы вообще ни разу не писали на C#, имеет смысл почитать какие-нибудь книги или онлайн учебники. Для Вашей задачи будет достаточно хотя бы узнать как писать программу, выводящую "Hello World" на экран и узнать о базовых типах переменных.

Приведу пример программы "Hello World":

using System;

class Program

{

   static void Main()

   {

       Console.WriteLine("Hello World");

   }

}

В этой программе новичку стоит только понимать, что программа выполняется внутри фигурных скобок, метода Main.

Дальше узнайте, что для хранения вещественных чисел используется тип переменных double.

А потом наберите в интернете "как округлять double до нужного числа знаков после запятой c#" или типа того.

В общем, когда Вам сказали найти ответ в интернете, имелось ввиду в поисковике, а не задавать вопрос на форуме.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота