Magomedrasul05555
28.08.2020 19:40

Составить программу для решения : 1)даны действительные, положительные числа x,y,z. выяснить, существует ли треугольник с длинами сторон x,y,z. если треугольник, то является ли он равносторонним? 2)дан одномерный массив. найти количество смен знака между соседними элементами массива. программа -паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Noziks4
25.05.2020 22:27

var x,y,z:real;
begin
readln(x,y,z);
if (x<y+z) and (y<x+z) and (z<x+y) then begin
if (x=y) and (y=z) then writeln('Ravnostoronnii') else writeln('Ne ravnostoronnii');
end else writeln('Ne vozmojno sostavit');
end.

 

var a:array[1..10]of integer;
i,sum:integer;
begin
for i:=1 to 10 do readln(a[i]);
for i:=1 to 9 do begin
if (a[i]>0) and (a[i+1]<0) then sum:=sum+1;
if (a[i]<0) and (a[i+1]>0) then sum:=sum+1;
end;
writeln(sum);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота