Войти
Регистрация
Спроси ai-bota
1sherlock2
03.08.2020 18:57
Написать программу на паскале: вычислить 15 значений функции y=2-sin x из диапазона [pi/4, pi/2]
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
yevdokimenkoal
19.12.2020 12:00
Чему будет равна переменная «a» при X:=12 после выполнения фрагмента программы с условным оператором: If x 0 then a:=2*x else a:= 3*x?...
sait14
19.06.2020 12:15
Какая информация может быть на слайде презентации...
diman129
07.11.2021 20:22
Архивтеу программалар 3 ответь...
AmooQ
11.03.2021 17:08
Доклад по ИКТ 8 класс на тему: ,,Что я ценю в интернете . 5-8 предложений....
nozim21tx
18.04.2020 22:11
ИМЕННО СЕЙЧАС НУЖНА ВАЩА Надо все номера...
deluxe135
16.05.2021 11:16
Pascal одномерный массив. упорядочить каждые вторые ненулевые элементы последней четверти одномерного массива по убыванию обратных значений...
Muzahabiba
16.05.2021 11:16
Скорость первого автомобиля v1 км/ч, второго — v2 км/ч, расстояние между ними s км. определить расстояние между ними через t часов, если автомобили первоначально движутся...
Арте20
16.05.2021 11:16
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. всех и четных и нечетных. python3 через цикл while...
Romanus11
16.05.2021 11:16
Нужно написать программу на с++, которая будет решать введенные в нее производные, например 2x^5 = 10x^4, cosx = - sinx, вычислять ответ производной не нужно....
valdan2008
16.05.2021 11:16
Что это я не помню: тег какой-то?...
Ответ:
km546729
19.07.2020 10:20
Const
pi=3.14159265;
n=15;
var
a,b,h,x,y:real;
begin
a:=pi/4; b:=pi/2;
h:=(b-a)/(n-1);
x:=a;
while x<=b+h/2 do { h/2 - компенсация накопления погрешности }
begin
y:=2-sin(x);
Writeln(x:7:5,y:8:5);
x:=x+h
end
end.
Результат выполнения программы:
0.78540 1.29289
0.84150 1.25436
0.89760 1.21817
0.95370 1.18444
1.00980 1.15328
1.06590 1.12478
1.12200 1.09903
1.17810 1.07612
1.23420 1.05612
1.29030 1.03908
1.34640 1.02507
1.40250 1.01413
1.45860 1.00629
1.51470 1.00157
1.57080 1.00000
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота