Lotek
05.12.2020 09:51

Написать программу в паскале! задан целочисленный массив из 10 случайных целых чисел. выполнить сортировку элементов массива,стоящих на четных номерах по убыванию методом пузырька.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1234567891219
02.10.2020 09:31
Const   
b=10;
var   
a: array[1..b] of integer;   
i, j, k: integer;
begin
Randomize;
Write ('Pervonachalnii massiv: '); 
for i := 1 to b do 
begin   
a[i] := random(100);   
Write (a[i]:4); 
end; 
Writeln; 
for i := 1 to b-1 do   
for j := 1 to b-i do   
if a[j] > a[j+1] then     
begin       
k := a[j];       
a[j] := a[j+1];       
a[j+1] := k;      
end;
 Write ('Otsortirovannii massiv: '); 
for i := 1 to b do 
begin   
Write (a[i]:4); 
end; 
Writeln;
Readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота