viki040302
15.05.2023 06:58

Нужно решить 2 по информатике: 1) дан массив b[1..10] составьте программу которая находит количество элементов, которые больше своего соседа слева 2) дан массив b[1..10] составьте программу которая находит количество пар элементов с четным значением

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
avfvffg
02.10.2020 11:02
Вот решение первой задачки:

program Sosed;
uses Crt;
const n = 10;
type  Vec = array [1..n] of integer;
var  A: Vec;
     i, Col: integer;
begin
 ClrScr;
 Randomize;

 WriteLn('Massiv A:');
 for i:=1 to n do
     begin
        A[i]:= 10+random (90);
        Write (A[i]:4);
     end;
 WriteLn;
 Col:=0;
 for i:=2 to n do
   begin
     if A[i]<A[i-1] then
       Col:=Col+1;
   end;
 WriteLn;
 if Col<>0 then  Writeln('Col =', Col)
           else WriteLn('None!');
ReadLn;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота