димитриусис
22.05.2020 23:03

Написать программу решения : с клавиатуры вводят 9 вещественных чисел. занести в типизированный файл только отрицательные из введённых чисел. при форматирование файла учесть, что в файле данные должны быть записаны в строку.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1sherlock2
21.07.2020 10:03
Var
  i:integer;
  n:real;
  f:file of real;
begin
  Assign(f,'in.dat');
  Rewrite(f);
  Writeln('Введите 9 вещественных чисел');
  for i:=1 to 9 do begin Read(n); Write(f,n) end;
  Close(f)
end.

Пример ввода:
Введите 9 вещественных чисел
2 -5 1.45 -81.34 5.63e-10 0 -13.45e12 17.5353 -12e-3 1000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота