белка263
28.09.2020 23:40

Спрограммами по 1)дано натуральное число n. составьте программу, которая определяет сколько цифр этого числа кратны 3. 2)даны натуральные числа n, .составьте программу, которая определяет количество членов последовательности , являющихся нечетными числами.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
РоманРазумный
02.10.2020 12:27
 1)
var   
a,b,k : integer;  
begin 
readln (a);   
k := 0;     

While a > 0 do   
begin     
b := a mod 10;     
a := a div 10;     
if b mod 3 = 0 then       
k := k +1; 
end;   

writeln (k); 
end.

2)
 var   
n,a,i,k : integer;    
begin 
readln (n);   
k := 0;   
for i := 1 to n do   
begin     
readln (a);     
if a mod 2 = 1 then       
k := k +1;   
end;     
writeln (k); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота