Лерок228
02.06.2022 00:12

Написать программу в паскале. заполните массив из n элементов случайными числами в интервале [1,n] так, чтобы в массив обязательно вошли все числа от 1 до n (постройте случайную перестановку). пример: массив: 3 2 1 4 5

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anzhelikamilan
22.07.2020 06:57

//PascalABC.NET версия 3.4.0.1677 от 17.06.18

//Если программа не запускается, то обновите версию

const

   m = 99;

var

   n,i, j: integer;

   A,: Array[1..m] of integer;

begin

   Randomize;

   write('n = ');

   readln(n);

   

   for i := 1 to n do

   begin

       repeat

           j := Random(n) + 1

       until A[j] = 0;

       A[j] := i;

   end;

   

   for i := 1 to n do

       write(A[i]:3);

   writeln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота