babedinova
22.03.2023 05:19

Написать программу на языке паскаля . заданы координаты двух точек. определите, расположены ли они на одной окружности с центром в начале координат. результат присвоить символьной переменной. две точки находятся на одной окружности, если длины радиус-векторов, соединяющих эти точки с началом координат, равны (проверку на равенство осуществить с точностью до е=1.0е-3)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mironhik1
26.05.2020 03:17

var x1,x2,y1,y2:real;

a:string;
begin
readln(x1,y1);
readln(x2,y2);
if abs(x1/y1)=abs(x2/y2) then a:='Na odnoi okrujnosti' else a:='Ne na odnoi okrujnosti';

writeln(a);
end.

0,0(0 оценок)
Ответ:
8951992masha
26.05.2020 03:17

var x1,x2,y1,y2:real;

a:string;
begin
readln(x1,y1);
readln(x2,y2);
if abs(x1/y1)=abs(x2/y2) then a:='вот здесь я незнаюi';

writeln(a);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота