Aiden131
05.06.2022 00:03

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор, пока сумма не превысит 500. определить число членов суммы. значение суммы и число ее членов вывести на экран с соответствующими комментариями.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
helphelhelphelplease
22.07.2020 13:13
Вроде получилось:

var a,b,s:integer; 
begin
write('Числа = ');
for a:=1 to 100 do
begin
b:=a mod 3;
if (b = 0) then
begin
write(a,', ');
s:=s+a;
if((s > 500) and (s<520)) then break;
end;
end;
writeln('Сумма чисел = ', s);
end.

Результат:

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота