лизя5ррр
22.05.2021 11:12

Написать программу для решение - посчитать количество чисел от 1 до 1000 кратных 7 и честных ( провереть кратность 7 командой mod введя условие если в цикл)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
deniwolf200
23.07.2020 12:19
Var
   x,i,y:integer;
begin
  for i:=1 to 1000 do
    begin
      x:= i mod 7;
      if x=0 then
        begin
        y:=y+1;
        writeln (i);//строка выводит все числа кратные семи. она подлежит удалению
       end;
     end;
  writeln (y);
end.
0,0(0 оценок)
Ответ:
Kiss537
23.07.2020 12:19
Var
   count,i:integer;
begin
  i:=0;count:=0;
 repeat
     i:=i+2;
     if i mod 7 =0 then count:=count+1;
 until i>=1000;
 writeln(count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота