Chekinae
04.11.2020 17:40

составить программу, которая в каждом столбце двумерного массива случайных чисел находит наименьший элемент и записывает его индекс в одномерный массив.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Zena1112
23.07.2020 12:59
Const
n=10;m=8;
var
a:array[1..n,1..m]of integer;
b:array[1..m]of integer;
i,j,min:integer;
  begin
      for i:=1 to n do
         begin
             writeln;
                  for j:=1 to m do
                      begin
                          a[i,j]:=random(100);
                          write(a[i,j]:4);
                      end;
           end;
writeln;
for j:=1 to m do
   begin
       min:=a[i,1];
           for i:=1 to n do
                    if a[i,j]<min then
                         min:=a[i,j];
          b[j]:=min;
     end;
for i:=1 to m do
   write(b[i]:4);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота