Choch121
23.01.2020 00:44

Напишите программу, которая принимает с клавиатуры целое число х, а затем – серию из 29 дополнительных целых чисел (вводимых с клавиатуры). программа должна определить, сколько чисел в серии были равны значению переменной х, а сколько – были меньше значения переменной х.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
чувак65
02.10.2020 15:16
Program z2;
var x,i,n,r,m:integer;
begin
writeln('Введите x');
readln(x);
i:=1;
r:=0;
m:=0;
while(i<=29) do
begin
readln(n);
if(n=x) then
r:=r+1;
if(n<x) then
m:=m+1;
i:=i+1;
end;
writeln('Чисел, равных х ',r);
writeln('Чисел, меньше х ',m);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота