Loseva72
24.05.2020 09:48

Написать программу в паскале " для заданной квадратной матрицы 6*6 сформировать одномерный массив из ее диагональных элементов. вывести исходный массив и результаты вычисления."

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ggezzzz
02.10.2020 15:32
Const
n=6;
var
a:array[1..n,1..n]of integer;
b:array[1..n]of integer;
i,j:integer;
begin
   for i:=1 to n do
        begin
            for j:=1 to n do
                begin
                    a[i,j]:=random(100);
                    write(a[i,j]:4);  
                 end;
             b[i]:=a[i,i];
             writeln;
         end;
writeln;
for i:=1 to n do
    write(b[i]:4);
end.
вариант главной и побочной диагонали в одномерный массив
const
n=6;
var
a:array[1..n,1..n]of integer;
b:array[1..n*2]of integer;
i,j,k:integer;
   begin
       writeln;   
           for i:=1 to n do       
              begin           
                for j:=1 to n do               
                    begin                   
                        a[i,j]:=random(100);                   
                         write(a[i,j]:4);               
                    end;               
                      k:=k+1;             
                      b[k]:=a[i,i];             
                      k:=k+1;           
                       b[k]:=a[i,n+1-i];           
                  writeln;         
                 end;
writeln;
   for i:=1 to n*2 do 
          write(b[i]:4);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота