asatuchina1502
06.03.2021 15:51

Сделать ! напишите программу,которая в последовательности целых чисел определяет количество четных чисел кратных 3.программа получает на выход целые числа .количество введенных чисел неизвестно ,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность ).количество чисел не превышает 1000. введенные числа по модулю не превышают 30 000. программа должна вывести одно число: количество четных чисел,кратных 3 сделать ? ?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ЛимАнель
02.10.2020 16:05
Program a1;
var c,k,a: integer;
begin
a:=1;
while (a<>0) and (c<2)  do
begin 
read(a);
if (ABS(a)<30000) and (a<>0)  then
if ((a mod 2) = 0) and ((a mod 3)=0) then inc(k);
inc(c);
end;
writeln('kol = ',k);
end
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота