alinka393
12.05.2022 06:09

Нужно составить программу в паскале.

вычислить s=1! +2! +3! +…+n! используя подпрограмму-функцию вычисления факториала.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ryabchenko20021
02.10.2020 16:29

var

n,x,a,s:longint;

begin

read(n);

a:=1;

for x:=1 to n do

begin

a:=a*x;

s:=s+a;

end;

writeln(a);

end.

Программа будет работать для n<=12, если надо больше, то меняйте тип переменных a и s на int64 / uint64

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота