Даркфреш
28.12.2021 03:57

Написать программу вычисления и вывода в цикле 4-х результатов при х, заданном от -2 до 2 с шагом 0,4 при а=1.2 d=3.8 е в степени корень из х+1 при х больше чем о,4 z= ctgax+sinbx в остальных случаях

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lavira3
24.07.2020 16:54
PascalABC.Net
var
  a,d,x,z:real;
begin
  a:=1.2; d:=3.8; x:=-2;
  while x<=2 do begin
    if abs(x)>=0.0001 then begin { вот так приходится обходить нули! }
      if x>0.4 then z:=exp(sqrt(x+1))
      else z:=cos(a*x)/sin(a*x)+sin(d*x);
      Writeln('x=',x:7:4,', Z=',z:7:4)
    end
    else Writeln('Функция не определена для x=0');
    x:=x+0.4
  end
end.

Результат выполнения программы
x=-2.0000, Z= 0.1238
x=-1.6000, Z= 0.5659
x=-1.2000, Z= 0.8569
x=-0.8000, Z=-0.8015
x=-0.4000, Z=-2.9195
Функция не определена для x=0
x= 0.4000, Z= 2.9195
x= 0.8000, Z= 3.8253
x= 1.2000, Z= 4.4072
x= 1.6000, Z= 5.0151
x= 2.0000, Z= 5.6522
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота