oksanochkabob
14.04.2023 04:27

Составить программу на языке «рascal» для вычисления значений функции: 3sinx+8, если х

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
дрин2
26.07.2020 07:20
y=\begin {cases} \displaystyle 3\sin(x)+8, \quad x\ \textless \ \frac{\pi}{2} \\ \displaystyle 4\cos(2x), \quad x\geqslant \frac{\pi}{2} \end {cases}

uses Crt;
const
  Pi=3.14159265;
var
  x,y:real;
begin
  ClrScr;
  x:=0;
  while x<=Pi do begin
    if x<Pi/2 then y:=3*sin(x)+8
    else y:=4*cos(2*x);
    Writeln('x=',x:8:5,',  y=',y:8:5);
    x:=x+Pi/10
  end;
  ReadKey
end.

Тестовое решение:
x= 0.00000,  y= 8.00000
x= 0.31416,  y= 8.92705
x= 0.62832,  y= 9.76336
x= 0.94248,  y=10.42705
x= 1.25664,  y=10.85317
x= 1.57080,  y=-4.00000
x= 1.88496,  y=-3.23607
x= 2.19911,  y=-1.23607
x= 2.51327,  y= 1.23607
x= 2.82743,  y= 3.23607
x= 3.14159,  y= 4.00000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота