Nikita9244
08.02.2023 02:44

1)напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b . входные данные входная строк содержит два натуральных числа – границы диапазона a и b . гарантируется, что a ≤ b . выходные данные программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] . 2)напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a в остатке b , а при делении на c в остатке d . входные данные первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. вторая строка содержит натуральные числа c и d, также разделённые пробелом. гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c. выходные данные программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a в остатке b, а при делении на c в остатке d . если таких чисел нет, программа должна вывести число -1.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
1izzka000
02.10.2020 17:51
Обычно решают на Pascal, но я напишу на C++, он мне роднее)). Я конечно немножко по-другому реализовал (в плане ввода значений), но поставленную задачу выполняет.
1)
#include <stdio.h>
#inlcude <conio.h>
#include <iostream>
using namespace std;
int main()
{
 long a, b, i, sum=0;
 cin>>a; // Вводишь число a
 cin>>b; // Вводишь число b
  for (i=a;i<=b;i++)
    {
      sum=sum+(i*i);
    }
 cout<<sum; // выводим сумму квадратов чисел
 _getch();
}

2)
#include <stdio.h>
#inlcude <conio.h>
#include <iostream>
using namespace std;
int main()
{
 long a,b,c,d,i;
 bool z=false;
 cin>>a;
 cin>>b;
 cin>>c;
 cin>>d;
 for (i=10000; i<=99999; i++)
 {
   if (i % a==b && i % c==d) {z=true; cout<<i<<" ";}
 }
 if (z==false) {cout<<"-1";} // Выводится если нет чисел
_getch();
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота