valuchska
22.03.2023 07:27

Напишите программу. упорядочьте массив c[1..n] по убыванию. проверьте работу программы на заданном массиве

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
poloch
26.11.2022 23:34

В компьютерной безопасности в целом «уязвимостью» называется слабое место, которое позволяет злоумышленнику снизить уровень достоверности информации системы. Сочетаются три элемента: восприимчивость или недостаток системы, доступ злоумышленника к бреши и возможность злоумышленника ей воспользоваться. Что касается программного обеспечения, то «ошибка» в нем есть неисправность, заставляющая его выдавать неверный или неожиданный результат либо провоцирующая на непреднамеренное поведение (для своих разработчиков и пользователей). Другими словами, уязвимое программное обеспечение обычно работает исправно, но когда к нему подступают «иным образом» (т.е. со злым умыслом и соответствующими инструментами), может случиться всякое.

0,0(0 оценок)
Ответ:
FireLily
30.10.2022 06:38

#include <iostream>

using namespace std;

int main(){

unsigned short int Picture[4][4];

unsigned short int AverageBrightness = 0;

 

for(unsigned short int y = 0;y < 4;y++){

 for(unsigned short int x = 0;x < 4;x++){

  std::cin >> Picture[y][x];

  AverageBrightness = AverageBrightness + Picture[y][x];

 }

}

AverageBrightness = AverageBrightness / 16;

 

for(unsigned short int y = 0;y < 4;y++){

 for(unsigned short int x = 0;x < 4;x++){

  if(Picture[y][x] < AverageBrightness){

   Picture[y][x] = 0;

  }else{

   Picture[y][x] = 255;

  }

 }

}

 

for(unsigned short int y = 0;y < 4;y++){

 for(unsigned short int x = 0;x < 4;x++){

  std::cout << Picture[y][x];

 }

}

 

return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота