12345Камила1
28.12.2022 23:50

60 написать программу решения квадратного уравнения: ax²+bx+c=0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Васютка3333
29.07.2020 11:54
Var
  a,b,c,D,x1,x2:double;
begin
  Write('Введите коэффициенты квадратного уравнения А В С: ');
  Read(a,b,c);
  if a=0 then
    Writeln('А не может равняться нулю: уравнение не будет квадратным')
  else begin
    D:=sqr(b)-4*a*c;
    if D<0 then Writeln('Нет корней')
    else
      if D=0 then Writeln('x=',-b/(2*a))
      else begin
        D:=sqrt(D);
        x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a);
        Writeln('x1=',x1,', x2=',x2)
      end
  end
end.

Тестовое решение:
Введите коэффициенты квадратного уравнения А В С: 2 -5 3
x1=1, x2=1.5
0,0(0 оценок)
Ответ:
alinahan444
29.07.2020 11:54
Var a,b,c,D,x1,x2:double; begin Write('Введите коэффициенты квадратного уравнения А В С: '); Read(a,b,c); if a=0 then Writeln('А не может равняться нулю: уравнение не будет квадратным') else begin D:=sqr(b)-4*a*c; if D<0 then Writeln('Нет корней') else if D=0 then Writeln('x=',-b/(2*a)) else begin D:=sqrt(D); x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a); Writeln('x1=',x1,', x2=',x2) end end end. Тестовое решение: Введите коэффициенты квадратного уравнения А В С: 2 -5 3 x1=1, x2=1.5 ответ у модератора совершенно верен.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота