Составьте программу, которая заполняет массива а [1..8] соучайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и суумму элементов массива с нечетными значениями

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ClarisVerbis
29.07.2020 13:55
Program prog;
var a: array [1..8] of integer;
    k,s,i: integer;

begin
randomize;

for i:=1 to 8 do
begin
a[i]:=random(10)+1;
writeln('a[',i,'] = ', a[i]);
if a[i] mod 2 = 0 then
k:=k+1
else
s:=s+a[i];
end;
writeln;
writeln('Kolichestvo chetnyh k = ', k);
writeln('Summa nechetnyh S = ', s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота