alina1923
27.12.2021 16:33

Написать программу на си определить, можно ли построить треугольник со сторонами a, b и c. если можно, то определите его вид(прямоугольный, тупоугольный, остроугольный) и найдите его площать по формуле герона.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
милуя
22.03.2020 03:28

#include <iostream>

#include <fstream>

#include <ctime>

#define SIZE 30

signed main()

{

setlocale(LC_ALL, "Rus");

srand(time(NULL));

int arr[SIZE];

long prod = 1;

std::cout << "Сгенерированный массив: ";

for (int i = 0; i < SIZE; i++) {

 arr[i] = rand() % 10;

 std::cout << arr[i] << " ";

}

 

for (int i = 0; i < SIZE; i += 2) {

 prod *= arr[i];

}

std::cout << "\nПроизведение элементов массив с четными номерами: " << prod;

std::ofstream fout("my.txt");

fout << prod;

return 0;

}

0,0(0 оценок)
Ответ:
VitalЯ
06.06.2020 19:53

1. 9

2.15

3. 0

4. 48

5. 5

6. 60

7. 3

8.

9. 48

10. 26

Объяснение:

Если мы напишем программу, то она сможет посчитать кол-во, повторений. В 3 почему 0, это из-за того что цикл не выполниться ни разу. В 4 почему 48, да потому что мы от 8 - 3 = 5, значит цикл повториться 5 раз, следовательно идём таким путём:

0. S = 8;

1.  S = 16; // 8 + 8

2. S = 24. // 16 + 8

3. S = 32; // 24 + 8

4. S = 40; // 32 + 8

5. S = 48 // 40 + 8

10 Вопрос можно решить и вторым кстати он считается как самый быстрый.

С = 50;

1. 9 - 1 = 8, цикл должен выполниться 8 раз

2. Мы видем что в теле программы c = c - 3, значит 8 * 3 = 24

3.  Следовательно c = 50 - 24

ответ 26

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота