MSТигруля
22.10.2020 08:15

Написать программу вычисления значения переменной а по формуле : a=y²×m-sin(m)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Yyyyyyyyy1
06.04.2022 05:26
Корпоративные требования к почтовой перепискеписьмо состоит из трех частей1. Обращение2. текст письма3. Подпись4. исполнитель или сотрудник для связи с полными координатами(адреса: почтовый,E-mail, IСQ,телефон)
Сетевой этикет
Сетево́й этике́т (сетикет, нетикет — неологизм, является слиянием слов «сеть» (англ. net) и «этикет») — правила поведения, общения в Сети, традиции и культура интернет-сообщества, которых придерживается большинство. Это понятие появилось в середине 80-х годов XX века в эхоконференциях сети FIDO. Некоторые из правил сетевого этикета присутствуют в RFC 1855 (английский вариант).
Правила этикета не являются всеобщими и жестко установленными — в разных сообществах они могут значительно различаться. Так как основная цель этикета состоит в том, чтобы не затруднять общение в сообществе, правила могут устанавливаться исходя из целей сообщества, принятого стиля общения, технических ограничений, и т. д. Некоторые правила записаны, и даже оформляются в виде формального устава, а иногда и просто в виде списка, другие правила нигде не записаны, но известны большинству членов сообщества и строго соблюдаются.
0,0(0 оценок)
Ответ:
topova1
16.05.2021 04:18
1. Современное решение, когда можно решить "в одну строку"

// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('S=',ReadSeqInteger(3).Select(n->n.ToString
    .Where(d->Pos(d,'13579')>0)).SelectMany(c->c)
    .Select(c->c.ToDigit).Sum)
end.

Пример
252 337 105
S=24

2. А примерно вот так учат писать в школе - долго и длинно (да и не особо понятно)

var
  m,i,j,s,d:integer;
begin
  s:=0;
  for i:=1 to 3 do begin
    Read(m);
    for j:=1 to 3 do begin
      d:=m mod 10;
      if d mod 2<>0 then s:=s+d;
      m:=m div 10
      end
    end;
  Writeln('S=',s)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота