9fhneh
18.08.2022 23:09

Написать программу в паскале найти сумму чётных натуральных чисел в промежутке от n1 до n2. pascal abc.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
херфигзнает
02.10.2020 23:11
1. "Школьное" решение
// PascalABC.Net 3.0, сборка 1064
var
  i,n1,n2:integer;
  s:longint;
begin
  Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
  s:=0;
  if n1 mod 2 = 0 then i:=n1 else i:=n1+1;
  while i<=n2 do begin s:=s+i; i:=i+2 end;
  Writeln('Сумма четных чисел в интервале равна ',s)
end.

Тестовое решение:
Введите интервал для вычисления суммы: 7 14
Сумма четных чисел в интервале равна 44

2. Современное решение
// PascalABC.Net 3.0, сборка 1064
var
  n1,n2:integer;
begin
  Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
  if Odd(n1) then Inc(n1);
  Writeln('Сумма четных чисел в интервале равна ',Range(n1,n2,2).Sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота