razdor1996Rqzdor
10.12.2020 16:24

Напишите программу для паскаля! дано натуральное число. найти число, получаемое удалением удалением из исходного всех цифр а.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Salazar01
07.09.2020 08:26
Var n,m,k,p,a:integer;
 begin
write('n='); readln(n);
write('a='); readln(a);
m:=0;p:=1;
while n<>0 do
 begin
 k:=n mod 10;
 if k<>a then begin m:=k*p+m; p:=p*10; end;
 n:=n div 10;
 end;
writeln('m=',m);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота